Black November🚀 BLACK NOVEMBER SALE HAS STARTED. GET DAILY OFFERS ON PRODUCTS WITH BADGE LABEL!Shop Now
Order Line: +254 722 974 623
Genuine products with official 1-year warranty • Fast Nairobi & Countrywide Delivery
Other
Official Warranty
Tenda A9 Wireless N300 Universal Range Extender

Tenda A9 Wireless N300 Universal Range Extender

SKU: MH-44090

KES 2,900

VAT inclusive · Genuine Products with Official 1-year warranty

1
Chat on WhatsApp about this item
Official 1-year warranty
100% Genuine Brand New Sealed
Same-day Nairobi (1-4h CBD) · KES 300
24h Countrywide · KES 600
Tenda A9 Wireless N300 Universal Range Extender

Tenda A9 Wireless N300 Universal Range Extender

Standard Edition

KES 2,900
Hardware & Performance

Technical Specifications

Detailed hardware, camera, battery, and display parameters for Tenda A9 Wireless N300 Universal Range Extender.

General

Antenna type;2 External 3dBi omni-directional antenna
Frequency;2.412 GHz
Data rate;2.4GHz: Up to 300Mbps
Transmission power ;<20dBm
Data rate802.11b : 11 Mbps | 802.11g : 54 Mbps | 802.11n : 300Mbps
Standard&protocolIEEE802.11b,IEEE 802.11g, IEEE 802.11n
Modulation802.11b: DSSS / BPSK / QPSK / CCK
802.11gOFDM / DSSS / BPSK / QPSK / CCK
802.11nOFDM / DSSS / BPSK / QPSK / CCK
Frequency2.412~2.484 GHz
Power16dBm Reception
Sensitivity11b: -95dBm
11g-76dBm
11n-73dBm
Antenna2 *3dBi external non-detachable
Standard versionRFC768 UDP | RFC791 IP | RFC792 ICMP | RFC793 TCP
Channel bandwidth20/40MHz (default)
Working modeRepeater Mode (Client AP)
Wireless securityEncryption Mode: Mix WPA-PSK/WPA2-PSK
Wpa algorithmTKIP DHCP
ServerSupport System Tool
Overview

Product Overview & Features

Official details, performance capabilities, and product highlights for Tenda A9 Wireless N300 Universal Range Extender.

Tenda A9 Wireless N300 Universal Range Extender Price in Kenya

Tenda A9 Wireless N300 Universal Range Extender Price in Kenya is Ksh. 2,900. Tenda A9 Wireless N300 Universal Range Extender is a wireless N300 universal range extender, specially designed to extend the existing WiFi coverage and improve the signal strength. With one button extension, smart signal LED, wall-mount design and universal compatibility, it is easy for users to boost wireless networking. Tenda A9 Wireless N300 Universal Range Extender is an ideal choice for you to eliminate WiFi dead zones and optimize your networking.

 

Tenda A9 Wireless N300 Universal Range Extender Technical Specifications

  • Data Rate: 802.11b : 11 Mbps | 802.11g : 54 Mbps | 802.11n : 300Mbps
  • Standard&Protocol: IEEE802.11b,IEEE 802.11g, IEEE 802.11n
  • Modulation: 802.11b: DSSS / BPSK / QPSK / CCK
  • 802.11g: OFDM / DSSS / BPSK / QPSK / CCK
  • 802.11n: OFDM / DSSS / BPSK / QPSK / CCK
  • Frequency: 2.412~2.484 GHz
  • Power: 16dBm Reception
  • Sensitivity: 11b: -95dBm
  • 11g: -76dBm
  • 11n: -73dBm
  • Antenna: 2 *3dBi external non-detachable
  • Standard Version: RFC768 UDP | RFC791 IP | RFC792 ICMP | RFC793 TCP
  • Channel Bandwidth: 20/40MHz (default)
  • Working Mode: Repeater Mode (Client AP)
  • Wireless Security: Encryption Mode: Mix WPA-PSK/WPA2-PSK
  • WPA Algorithm: TKIP DHCP
  • Server: Support System Tool

 

Shop now Networking Solutions in Kenya.

Customer Feedback

Verified Reviews & Ratings

–

Based on 0 verified reviews

No reviews yet

Be the first to share your experience with this product.

Recommended Alternatives

Related Products

Explore similar genuine devices from our Accessories collection.

View all Accessories →
New
JBL
JBL Bar 300 Multibeam

JBL Bar 300 Multibeam Specifications &…

KES 34,000
Nothing
Nothing Phone (4b)

Nothing Phone (4b) Specifications & Fe…

KES 47,000
Canon
Canon EOS Rebel Camera T7 EF-S 18-55mm IS II Kit

24.1 Megapixel CMOS Built-in Wi-Fi and…

KES 102,000
Xiaomi
Xiaomi WiFi Repeater Pro

Xiaomi WiFi Repeater Pro available at…

KES 2,999